On 06/08/14 14:32, Brad Jorsch (Anomie) wrote:
When api.php was basically the only API in MediaWiki,
calling it "the
API" worked well. But now we've got a Parsoid API, Gabriel's work on a
REST content API, Gabriel's work on an internal storage API, and more
on the way. So just saying "the API" is getting confusing.
So let's bikeshed a reasonably short name for it that isn't something
awful like "the api.php API". I'm horrible at naming.
How about "the action API"? The fact that it is organised in a
hierarchy of actions distinguishes it from REST, which is organised as
a hierarchy of objects. The term "action" also distinguishes it from RPC.
-- Tim Starling