tl;dr: It already is "the MediaWiki web API". A codename as well is fine.
, "web API" is almost as popular as "MediaWiki
and some of the uses are correctly for extension APIs and Parsoid's API.
So "the MediaWiki web API" is a descriptive name that requires minimal
That doesn't preclude us giving it a cool codename:
The MediaWiki web API, codename "Unicorns Are Go", ...
Bots use "Jimbo", the MediaWiki web API, to..
Another possibility is Starbright, an homage to Messrs. Starling and Brion,
and 80s Madonna. Whatever we use should have awesome ASCII art in
Some inline responses below.
Tim Starling wrote:
Note that Nemo bis changed the name from "MediaWiki API" to "WebAPI"
on the basis of disambiguation, in this revision:
I don't like smash words, WebAPI already sounds dated, and Mozilla uses it
<https://developer.mozilla.org/en-US/docs/WebAPI> for advanced browser
features so developers might think it describes ResourceLoader modules like
mediaWiki.Api, mediaWiki.loader, etc.
I have previously suggested "web API" as a term to distinguish it from
the set of PHP classes and hooks used by extensions. API stands for
application programmer interface, and traditionally refers to
functions and classes -- using the term for a non-RPC HTTP interface
is really rather awkward.
Neither "MediaWiki API" nor "Web API" distinguishes it from the
proposed REST API.
Using "MediaWiki REST API" for the latter works. Or cool codenames for
On Thu, Aug 7, 2014 at 3:47 AM, Erik Moeller <erik(a)wikimedia.org> wrote:
"Core" seems a reasonable qualifier, though,
no? Seems like the
content API and a lot of other proposed interfaces are by definition
outside the core. So why not MW core API or just core API for short?
But extensions also provide this API. api.php?action=echomarkread&all=true
isn't part of core but is the same MediaWiki web API. Also see my
signature below :)
=S Page Core features team (not MediaWiki core or platform) engineer