I don't really like this. If I see DataValues and DataValuesInterfaces side by side, i'd assume that DataValuesInterfaces contains the interfaces and DataValues the implementations - while, if I understand correctly, DataValues contains the interfaces and DataValuesInterfaces contains *more* interfaces.

That is true. Perhaps this is somewhat hard to avoid without renaming DataValues itself. Something like "DataValuesCore" or "DataValuesBase" can help to avoid confusion. At this point we cannot really change the repo name, change the namespace, or change the Composer package name without causing lots of hassle though. We can still rename it, but then should hold into account the name will not be fully reflected at all places, which might in itself cause confusion.

Improving DataValuesInterfaces in such a way that it does not cause the kind of confusion described would be preferred. Still have not seen any better suggestions though.


Jeroen De Dauw
Don't panic. Don't be evil. ~=[,,_,,]:3