It was a bug on our end - we were incorrectly handling urls, which caused python to try and interpret the image data as text. Not surprisingly, this results in errors. and both fix this (but in different and complementary ways).

For now, the easiest fix is opening your generated family file (families/ and removing the u in both u'' and u'/w'.


On 21 August 2013 11:36, AugurNZ <> wrote:
Hi, I was pointed here from #pywikipediabot on Freenode IRC. I am using
Pywikipediabot (trunk) revision 11781 under Ubuntu 12.04. I'm having no
success using the script. It keeps failing with the following
error message...

augur@ubuntu:/home/augur/pywikipedia# python -family:tropical
-keep -filename:Pwbicon.png -noverify Pwbicon.png "The Pywikipediabot
No handlers could be found for logger "pywiki"
Reading file Pwbicon.png
The suggested description is:
The Pywikipediabot icon
Uploading file to tropical:en via API....
ERROR: UnicodeDecodeError: 'ascii' codec can't decode byte 0x89 in
position 654: ordinal not in range(128)
WARNING: Could not open ''. Maybe
the server or
 your connection is down. Retrying in 1 minutes...

I can perform other actions on with my bot, such as
using, etc. I have also tried using a different
-family: and logging in to (where I also have a valid
bot account) and tried uploading the image file there, with the same

I'm not a python expert, in fact I'm barely a python novice. I came across
this information which may be relevant though...


ps. sorry if this is a repeat of a previous message. I wasn't registered
on the list when I first sent this, but I am now.

Pywikipedia-l mailing list