For me it seems that you have an HTTP error on uploading and the error message contains a non-ASCII character. This is an old problem, nobody could solve it by this time.
Does your uploaded file contain none-ASCII chars?

2013/8/21 AugurNZ <>
Hi, I was pointed here from #pywikipediabot on Freenode IRC. I am using
Pywikipediabot (trunk) revision 11781 under Ubuntu 12.04. I'm having no
success using the script. It keeps failing with the following
error message...

augur@ubuntu:/home/augur/pywikipedia# python -family:tropical
-keep -filename:Pwbicon.png -noverify Pwbicon.png "The Pywikipediabot
No handlers could be found for logger "pywiki"
Reading file Pwbicon.png
The suggested description is:
The Pywikipediabot icon
Uploading file to tropical:en via API....
ERROR: UnicodeDecodeError: 'ascii' codec can't decode byte 0x89 in
position 654: ordinal not in range(128)
WARNING: Could not open ''. Maybe
the server or
 your connection is down. Retrying in 1 minutes...

I can perform other actions on with my bot, such as
using, etc. I have also tried using a different
-family: and logging in to (where I also have a valid
bot account) and tried uploading the image file there, with the same

I'm not a python expert, in fact I'm barely a python novice. I came across
this information which may be relevant though...


ps. sorry if this is a repeat of a previous message. I wasn't registered
on the list when I first sent this, but I am now.

Pywikipedia-l mailing list