I finished writing the guideline:https://www.mediawiki.org/wiki/Manual:Pywikibot/Development_guideline
Reading the pep8 about naming style was interesting. (as pep8 name of our project has to be "pywikibot" not "Pywikibot", or "PyWikiBot")
- Names of classes has to be CapWord (use DataPage instead of Datapage, datapage or data_page)
- Names of functions and methods has to be lowercase with underscores
for better readability (e.g. set_label instead setLabel, or SetLabel)
- Names of errors has to be CapWord with "Error" suffix (like NoPageError)
Please anyone check the page and if we can reach a consensus about the guideline, we'll start enforcing it and adding it to pages.
Please feel free to edit (and add things) mercilessly