I have MediaWiki 1.4 running on mysql 3.23
When I first installed MediaWiki it was on a different mysql version, I forget the exact number. After I upgraded the searchindex keeps getting corrupted every couple of weeks.
This is noticed by the users when they save a page they get "Internal DB error", when I turn on more verbose warnings, it shows an error when updated the SearchIndex table.
Sure enough when I check the table with "Check table" it show it as "crashed" I can easily repair it but I wan't to find the root cause of why it is crashing.
I assume it has something to do with me upgrading mysql after the install. Any ideas on how to fix it?
Chris McIntosh
Are you using InnoDB on the search table? I don't believe it supports full text. (Use MyISAM instead for that one.)
Are you sure that the server is stable? To me, it sounds like more of a MySQL thing then a MediaWiki thing (but I'll let the true experts decide that).
On 6/17/05, Chris McIntosh cmcintosh@gmail.com wrote:
I have MediaWiki 1.4 running on mysql 3.23
When I first installed MediaWiki it was on a different mysql version, I forget the exact number. After I upgraded the searchindex keeps getting corrupted every couple of weeks.
This is noticed by the users when they save a page they get "Internal DB error", when I turn on more verbose warnings, it shows an error when updated the SearchIndex table.
Sure enough when I check the table with "Check table" it show it as "crashed" I can easily repair it but I wan't to find the root cause of why it is crashing.
I assume it has something to do with me upgrading mysql after the install. Any ideas on how to fix it?
Chris McIntosh _______________________________________________ MediaWiki-l mailing list MediaWiki-l@Wikimedia.org http://mail.wikipedia.org/mailman/listinfo/mediawiki-l
Chris McIntosh wrote:
Sure enough when I check the table with "Check table" it show it as "crashed" I can easily repair it but I wan't to find the root cause of why it is crashing.
Most likely possibilities in order: * Your server/operating system is crashing or being shut down incorrectly, or MySQL process is being killed instead of shut down in an orderly fashion -- check system log and MySQL's error log. * Overheating, faulty memory or other hardware problem is causing MySQL to crash out -- check MySQL's error log. * >2gb memory committment on 32-bit machine or other configuration error is causing MySQL to crash out -- check MySQL's error log. * Bug in MySQL is causing MySQL to crash out -- check MySQL's error log.
You might try a MySQL support forum if you need more detail here.
-- brion vibber (brion @ pobox.com)
So I know nothing is wrong with the mysql system or the hardware because I am running 5 other instances of MediaWiki all installed after I upgraded mysql as different database on the same server. Plus some miscellaneous database that also have no problems. It is just this one DB that is having problems.
Ther other databases actually get used more heavly, this one is pretty light, and it only started happening after I upgraded mysql.
I am also researching if it is a mysql thing, but I just wanted to see if perhaps the installer picked some commands differently since I installed it with a different version of mysql now the upgrade might be confusing it.
Chris
On 6/17/05, Brion Vibber brion@pobox.com wrote:
Chris McIntosh wrote:
Sure enough when I check the table with "Check table" it show it as "crashed" I can easily repair it but I wan't to find the root cause of why it is crashing.
Most likely possibilities in order:
- Your server/operating system is crashing or being shut down
incorrectly, or MySQL process is being killed instead of shut down in an orderly fashion -- check system log and MySQL's error log.
- Overheating, faulty memory or other hardware problem is causing MySQL
to crash out -- check MySQL's error log.
2gb memory committment on 32-bit machine or other configuration erroris causing MySQL to crash out -- check MySQL's error log.
- Bug in MySQL is causing MySQL to crash out -- check MySQL's error log.
You might try a MySQL support forum if you need more detail here.
-- brion vibber (brion @ pobox.com)
MediaWiki-l mailing list MediaWiki-l@Wikimedia.org http://mail.wikipedia.org/mailman/listinfo/mediawiki-l
Chris McIntosh wrote:
So I know nothing is wrong with the mysql system or the hardware because I am running 5 other instances of MediaWiki all installed after I upgraded mysql as different database on the same server. Plus some miscellaneous database that also have no problems. It is just this one DB that is having problems.
Ther other databases actually get used more heavly, this one is pretty light, and it only started happening after I upgraded mysql.
I am also researching if it is a mysql thing, but I just wanted to see if perhaps the installer picked some commands differently since I installed it with a different version of mysql now the upgrade might be confusing it.
Well, let me put it this way: It is *not normal* for a database to be marked as crashed.
If that is the case, then either: * MySQL is not being shut down cleanly * There is a hardware problem causing crashes or data corruption * There is a software error causing crashes or data corruption
In any of the software cases, culprit software will be one or more of: * MySQL * The operating system
Culprit hardware may include: * Bad memory * Overheating CPU * Disk errors
MediaWiki has no access to MySQL's table files, and nothing in MediaWiki can possibly _cause_ these failure conditions, though of course _using_ MediaWiki can _trigger_ a failure condition by exercising a failing code path in MySQL or causing a previously corrupted data page to be loaded when searching a particular database.
Not seeing a problem with other databases doesn't disprove any of those cases; problems may well manifest only or mostly when triggered by a particular bit of the disk, a particular use of memory, loading a particular bit of a file that's been previously corrupted, etc. A bug in MySQL for instance might only get triggered when certain conditions are present such as the size and relative position of items in the index, conditinos which are not present in your other databases.
I would recommend the following: * Check your MySQL logs for crashes, etc. MySQL will usually restart itself automatically so you may not be noticing them. Don't assume there's nothing to see -- check! * Check your operating system logs for crashes, out of memory conditions, etc. * If warranted by what you find in the logs, run a memory test on the MySQL server machine. * Drop and recreate the searchindex table to see if there's any change in behavior. * Ensure you're running the current release of your MySQL version. If 3.23.x continues to be problematic, consider the current 4.0.x release instead. * Check with MySQL support forums / mailing lists / irc, with symptoms including suspicious log data and what you've tried so far. * If necessary, file bug reports to and/or obtain technical support directly from MySQL.
-- brion vibber (brion @ pobox.com)
mediawiki-l@lists.wikimedia.org