As a workaround, you can change all the f strings into python < 3.6 compatible strings and push that to some git repository and install from there with pip install git+ See  < > for details.
Chico Venancio 

Em qua, 31 de jul de 2019 às 11:03, Bryan Davis <> escreveu:
On Tue, Jul 30, 2019 at 7:30 PM Huji Lee <> wrote:
> Good catch! It seems like we have 3.5.3 on Toolforge.  Being a light user of pip, I have no clue how to force installation of an earlier version of the python module. Any advice on that?

You can use `pip install <package_name>==<version>` to install an
exact version. See
for a bit more detail.

Your particular problem sounds like a bug in the upstream packaging as
well. The version of the library that requires f-strings should have
been marked as requiring Python >= 3.6 in pypi. That would have let
pip figure out that it needed to install a different version of the
library for the Python 3.5 runtime.

I would like to get support for Python 3.7 added to the Toolforge
Kubernetes environment "soon". It should be relatively easy once we
have a Debian Buster base container to extend.

Bryan Davis              Technical Engagement      Wikimedia Foundation
Principal Software Engineer                               Boise, ID USA
[[m:User:BDavis_(WMF)]]                                      irc: bd808

Wikimedia Cloud Services mailing list (formerly